docker在centos7容器中安装宝塔重启端口映射失败,容器重启端口映射失败.

admin6年前IT技术2008

 问题的出现大家都以为是centos容器重启之后,导致端口映射失败,其实不是的,我之前也误解成是这个原因,硬刚了4天,才发现了问题所在

真正的原因:centos容器重启之后,宝塔面板没有能启动起来,需要在宿主机中输入命令启动:

命令如下

sudo docker exec 容器ID /etc/init.d/bt start && sudo docker exec 容器ID /etc/init.d/nginx start && sudo docker exec 容器ID /etc/init.d/php-fpm-56 start && sudo docker exec 容器ID /etc/init.d/mysqld start

相关文章

不同思想管理不同员工

不同思想管理不同员工普通员工最重要的是有较强的责任心,能干好交给他们必须完成的基础工作。这些员工也许只要求企业能给一个较高的收入、工作相对稳定且尽可能少地承担各种风险,不能要求他们对企业绝对的忠诚。这...

通过IP获取MAC地址

关键知识点:ARP缓存时间是十分钟;实现的命令是:第一步  ping  ip第二部  arp -a基础解释:在底层的网络通信中,两个节点想要相互通信,必须先要知道源与目标...

openclaw安装教程

http://127.0.0.1:18789,在设置里填 API。重新运行孵化命令:在终端输入 openclaw hatchWindows10 中国大陆环境 从零安装【原版 OpenClaw】+配置N...

LINUX-centos7服务器环境安装的那些坑

LINUX-centos7服务器环境安装的那些坑亲自测试能用的第一步 安装php一定要加上--skip-broken,否则根本无法安装,依赖的程序实在是太多了,我走过这个弯路; yum -y...

亚马逊“傲娇”!拒绝与PayPal合作

一个平台如果没有自己的支付系统,是一个平台最大的悲剧,ebay这几年不行了,其他原因不好说,但是他长期使用paypal的支付接口,就说明是一大败笔,长期泄露自己的会员交易数据!!!! 亚马逊...

汇成减速机行业建站CMS系统v13.1

汇成减速机行业建站CMS系统v13.1˂a target="_blank" href="download/jixie/jiexiejsjv131.rar"˃官方下载汇成企业网站管理系统为中小企业免费建...

发表评论    

◎欢迎参与讨论,请在这里发表您的看法、交流您的观点。