docker在centos7容器中安装宝塔重启端口映射失败,容器重启端口映射失败.

admin6年前IT技术1985

 问题的出现大家都以为是centos容器重启之后,导致端口映射失败,其实不是的,我之前也误解成是这个原因,硬刚了4天,才发现了问题所在

真正的原因:centos容器重启之后,宝塔面板没有能启动起来,需要在宿主机中输入命令启动:

命令如下

sudo docker exec 容器ID /etc/init.d/bt start && sudo docker exec 容器ID /etc/init.d/nginx start && sudo docker exec 容器ID /etc/init.d/php-fpm-56 start && sudo docker exec 容器ID /etc/init.d/mysqld start

相关文章

Axure RP 8设置动态面板状态的方法

Axure RP 8设置动态面板状态的方法

设置动态面板状态需要注意鼠标单击需要设置面板状态,而不是显示隐藏,不然无法控制动态面板里的各个元件的显示与隐藏 ˂a href="post/523.html"˃...

centos7 配置秘钥登录

默认情况下, 我同时允许密码和秘钥登录, 所有不用改配置文件.第一步, 先 生成秘钥对, ssh-keygen, 一路回车即可.然后在 ~/.ssh 目录下会发现两个文件...

女白领发量剩3成 中医:遗传加上压力大常熬夜|女白|领发-社会资讯-川北在线

女白领发量剩3成 中医:遗传加上压力大常熬夜 江苏南京一公司女白领,今年25岁。她因遗传原因,加上平时工作压力大,经常熬夜,脱发严重,现在发量只剩30%。中医魏跃钢说,国内脱发人数非常庞大,多数是20...

美国年轻人都在玩哪些App[转]

美国年轻人都在玩哪些App[转]

Facebook 它对我们这个年龄的人来说已经死了,Facebook 是我们中学时候玩儿的,但是现在就像尴尬的家庭晚宴一样鸡肋,你会经常遇到这个问题:「别人都用 Facebook,你怎么不用?」(貌似...

在Hyper-V 虚拟机环境设置centos 7固定IP

在Hyper-V 虚拟机环境设置centos 7固定IP

Hyper-V 管理器的自动停止操作的选项里,设置"保持虚拟机状态"如下图所示:...

树莓派安装软件

 apt-get install ...

发表评论    

◎欢迎参与讨论,请在这里发表您的看法、交流您的观点。