docker在centos7容器中安装宝塔重启端口映射失败,容器重启端口映射失败.

admin6年前IT技术1992

 问题的出现大家都以为是centos容器重启之后,导致端口映射失败,其实不是的,我之前也误解成是这个原因,硬刚了4天,才发现了问题所在

真正的原因:centos容器重启之后,宝塔面板没有能启动起来,需要在宿主机中输入命令启动:

命令如下

sudo docker exec 容器ID /etc/init.d/bt start && sudo docker exec 容器ID /etc/init.d/nginx start && sudo docker exec 容器ID /etc/init.d/php-fpm-56 start && sudo docker exec 容器ID /etc/init.d/mysqld start

相关文章

汇成装潢行业企业网站系统vII2.3

汇成装潢行业企业网站系统vII2.1管理地址:http://您的网站/admin/login.asp后台帐号:admin后台密码:admin˂a target="_blank" href="hangy...

php – DOMXpath – 获取一个元素的href属性和文本值[转]

原文https://stackoverflow.com/questions/6820429/domxpath-get-href-attribute-and-text-value-of-an-a-ele...

excel在第三个空格插入数据

=LEFT(RIGHT(C63,LEN(C63)-FIND(" ",C63,FIND(" ",C63,FIND(" ",C63)+1)+1)...

火车头正则过滤emoji表情

由于火车头是C#开发的,所以大家写不了正则,就要在网上搜索C#正则过滤emoji表情 正则表达式如下\p{Cs}这个比较不错下面2个作为补充(\ud83c[\udf00-\udfff])|(...

centos7 配置秘钥登录

默认情况下, 我同时允许密码和秘钥登录, 所有不用改配置文件.第一步, 先 生成秘钥对, ssh-keygen, 一路回车即可.然后在 ~/.ssh 目录下会发现两个文件...

视频处理注意要点

 1.拍视频的项目,你必须熟练不然容易占用时间2.不要怕视频长,可以修减3.视频的宽度是500 高度是1000,能保证在手机上播放是清晰的 pre减掉的视频块要用下面的拉伸,不然只...

发表评论    

◎欢迎参与讨论,请在这里发表您的看法、交流您的观点。