docker在centos7容器中安装宝塔重启端口映射失败,容器重启端口映射失败.

admin6年前IT技术2005

 问题的出现大家都以为是centos容器重启之后,导致端口映射失败,其实不是的,我之前也误解成是这个原因,硬刚了4天,才发现了问题所在

真正的原因:centos容器重启之后,宝塔面板没有能启动起来,需要在宿主机中输入命令启动:

命令如下

sudo docker exec 容器ID /etc/init.d/bt start && sudo docker exec 容器ID /etc/init.d/nginx start && sudo docker exec 容器ID /etc/init.d/php-fpm-56 start && sudo docker exec 容器ID /etc/init.d/mysqld start

相关文章

浑浑噩噩从业互联网15年

03-08年纯粹的技术宅男一枚08-18年转行做运营推广-----寻找从网络上怎么把技术变现此后发现了很多互联网推广的知识与秘密,让我从此铁了心从事此职业. 互联网赚钱 游戏  电...

windows下安装、卸载mysql服务

windows下安装、卸载mysql服务2012年03月09日 16:30:20阅读数:52062 将下载下来的mysql解压到指定目录下(如:d:\mysql)安装服务 在命令行输入d:\...

codex 用于amazon主图与详情A+设计得skill

通过聊天让codex安装 https://github.com/RongjieTang/rongjie-amazon-design上传一张主题与你喜欢得设计风格的A+详情页图片或者主图图片告...

树莓派安装软件

 apt-get install ...

WireGuard 安装脚本

WireGuard 安装脚本

 执行结束后,会输出一个二维码,可直接用 WireGuard App 扫描导入。4. 客户端配置文件路径/etc/wireguard/client.conf可复制到 Windows、Mac、...

google apptore在线打包下载工具

https://apkpure.com/cn/apk-downloader-browser-extension?install=true...

发表评论    

◎欢迎参与讨论,请在这里发表您的看法、交流您的观点。