docker在centos7容器中安装宝塔重启端口映射失败,容器重启端口映射失败.

admin6年前IT技术2012

 问题的出现大家都以为是centos容器重启之后,导致端口映射失败,其实不是的,我之前也误解成是这个原因,硬刚了4天,才发现了问题所在

真正的原因:centos容器重启之后,宝塔面板没有能启动起来,需要在宿主机中输入命令启动:

命令如下

sudo docker exec 容器ID /etc/init.d/bt start && sudo docker exec 容器ID /etc/init.d/nginx start && sudo docker exec 容器ID /etc/init.d/php-fpm-56 start && sudo docker exec 容器ID /etc/init.d/mysqld start

相关文章

Android Studio下载sdk失败的解决方案

在浏览器打开这个网站http://ping.chinaz.com/dl.google.com或者:https://www.ping.cn/ping/dl.google.com他会列出一个ip列表,挨个...

KindEditor的图片仓库绑定用户ID的方法

在新建目录的时候,只能一个一个的建立,不能一次性的建两个目录或者在空目录路径之后新建目录...

Hyper-V虚拟机固定IP地址(手把手教设置)

链接虚拟机修改网络配置文件输入指令sudo vi /etc/sysconfig/network-scripts/ifcfg-eth0然后 输入  按  i  键 再按回车...

IOS14.2无法连接l2tp的解决方案,iphone无法连接l2tp的解决方案,配置服务器以将 SHA-256 哈希的输出截断至 128 位

IOS14.2无法连接l2tp的解决方案,iphone无法连接l2tp的解决方案,配置服务器以将 SHA-256 哈希的输出截断至 128 位

 解决方案其实很简单:以centos 7的l2tp方案为例:修改文件/etc/ipsec.conf里的"sha2-truncbug=yes"为"sha2-tru...

LINUX-centos7服务器环境安装的那些坑

LINUX-centos7服务器环境安装的那些坑亲自测试能用的第一步 安装php一定要加上--skip-broken,否则根本无法安装,依赖的程序实在是太多了,我走过这个弯路; yum -y...

汇成制造行业CMS企业建站系统v11.1

汇成制造行业企业网站cms系统v11.1管理地址:http://您的网站/admin/login.asp后台帐号:admin后台密码:admin演示地址:˂a href="ceshi/zhizhao/...

发表评论    

◎欢迎参与讨论,请在这里发表您的看法、交流您的观点。