docker在centos7容器中安装宝塔重启端口映射失败,容器重启端口映射失败.

admin6年前IT技术1986

 问题的出现大家都以为是centos容器重启之后,导致端口映射失败,其实不是的,我之前也误解成是这个原因,硬刚了4天,才发现了问题所在

真正的原因:centos容器重启之后,宝塔面板没有能启动起来,需要在宿主机中输入命令启动:

命令如下

sudo docker exec 容器ID /etc/init.d/bt start && sudo docker exec 容器ID /etc/init.d/nginx start && sudo docker exec 容器ID /etc/init.d/php-fpm-56 start && sudo docker exec 容器ID /etc/init.d/mysqld start

相关文章

IPI得分监控

 IPI 350分以上库存量不受限制每个季度重新评估一次库存超额费用将按每立方英尺每月10美元的费率收取。得分等于或高于350的卖家库存量没有限制,但仍然要正常交FBA短期和长期仓储费用。上...

magento1.9x系统加速

1.设置magento数据库模型 为单表查询:   在System > Configuration > Catalog > FrontEnd设置 ‘U...

Hyper-V虚拟机固定IP地址(手把手教设置)

链接虚拟机修改网络配置文件输入指令sudo vi /etc/sysconfig/network-scripts/ifcfg-eth0然后 输入  按  i  键 再按回车...

判断mysql字段是否为空

 字段内容为空有两种情况  1.为null  2.为字符串的空'' 字段 is null or trim(字段)=''...

magento1.9x在windows10环境下安装遇到的问题及解决方法

win10 wamp环境安装php7126   CURL组件安装之后需要重启电脑,不然不生效apache 开通伪静态功能:需要把#LoadModule access_compat_...

树莓派安装软件

 apt-get install ...

发表评论    

◎欢迎参与讨论,请在这里发表您的看法、交流您的观点。