docker在centos7容器中安装宝塔重启端口映射失败,容器重启端口映射失败.

admin6年前IT技术1987

 问题的出现大家都以为是centos容器重启之后,导致端口映射失败,其实不是的,我之前也误解成是这个原因,硬刚了4天,才发现了问题所在

真正的原因:centos容器重启之后,宝塔面板没有能启动起来,需要在宿主机中输入命令启动:

命令如下

sudo docker exec 容器ID /etc/init.d/bt start && sudo docker exec 容器ID /etc/init.d/nginx start && sudo docker exec 容器ID /etc/init.d/php-fpm-56 start && sudo docker exec 容器ID /etc/init.d/mysqld start

相关文章

Apache的几种常用配置

Apache是世界使用排名第一的Web服务器软件。它可以运行在几乎所有广泛使用的计算机平台上,由于其跨平台和安全性被广泛使用,是最流行的Web服务器端软件之一。     ...

WINDOWS 10 PPTP服务器的搭建流程

WINDOWS 10 PPTP服务器的搭建流程

Windows Server 2003/2008/2008 R2的方法是完全一样的,没有任何区别。不过2008 R2系统要先打开服务管理,添加角色,安装“网络策略和访问服务”,...

Android Studio4.1.3设置app全屏

 Android Studio4.1.3设置app全屏<style name="AppTheme.FullScreen">   ...

过滤emoji表情的正则表达式

\p{Cs}?imageView2/2/w/300/interlace/1/q/90^[\u4e00-\u9fa5]+$...

magento1.x开启调试模式

magento1.x开启调试模式

方法一设置:Current Configuration Scope: main website 通过后台控制台来操作,admin->configuration->develope...

二维码生成导航

http://twoyn.shengmake.nethttp://twalabo.shengmake.nethttp://twyilang.shengmake.nethttp://twyindu.sh...

发表评论    

◎欢迎参与讨论,请在这里发表您的看法、交流您的观点。