docker在centos7容器中安装宝塔重启端口映射失败,容器重启端口映射失败.

admin6年前IT技术2001

 问题的出现大家都以为是centos容器重启之后,导致端口映射失败,其实不是的,我之前也误解成是这个原因,硬刚了4天,才发现了问题所在

真正的原因:centos容器重启之后,宝塔面板没有能启动起来,需要在宿主机中输入命令启动:

命令如下

sudo docker exec 容器ID /etc/init.d/bt start && sudo docker exec 容器ID /etc/init.d/nginx start && sudo docker exec 容器ID /etc/init.d/php-fpm-56 start && sudo docker exec 容器ID /etc/init.d/mysqld start

相关文章

asp移动APP单页应用开发前端后端框架v1.0

asp移动APP单页应用开发前端后端框架v1.0简称aspwn  1.0在线演示 ˂a href="download/aspwn.zip" target="_blank"˃官方下载开发此套框...

magento2.x系统加速

magento2.x系统加速

1:在根目录运行以下命令,全站生成静态bin/magento setup:static-content:deploy2:编译整个网站,让网站加速50%  注意事项:要把PHP脚本内存限制设置...

二维码生成导航

http://twoyn.shengmake.nethttp://twalabo.shengmake.nethttp://twyilang.shengmake.nethttp://twyindu.sh...

解决方案2
打开的本地组策略

Win10远程连接的凭据不工作的解决方法

 把远程桌面工具的本地资源的打印机与剪贴板的勾勾取消解决方案2打开的本地组策略在右侧打开的窗口中双击“网络访问:本地账户的共享和安全模型”一项在打开的属性窗口中,我们...

汇成制造行业CMS企业建站系统v11.1

汇成制造行业企业网站cms系统v11.1管理地址:http://您的网站/admin/login.asp后台帐号:admin后台密码:admin演示地址:˂a href="ceshi/zhizhao/...

通过IP获取MAC地址

关键知识点:ARP缓存时间是十分钟;实现的命令是:第一步  ping  ip第二部  arp -a基础解释:在底层的网络通信中,两个节点想要相互通信,必须先要知道源与目标...

发表评论    

◎欢迎参与讨论,请在这里发表您的看法、交流您的观点。