docker在centos7容器中安装宝塔重启端口映射失败,容器重启端口映射失败.

admin6年前IT技术2004

 问题的出现大家都以为是centos容器重启之后,导致端口映射失败,其实不是的,我之前也误解成是这个原因,硬刚了4天,才发现了问题所在

真正的原因:centos容器重启之后,宝塔面板没有能启动起来,需要在宿主机中输入命令启动:

命令如下

sudo docker exec 容器ID /etc/init.d/bt start && sudo docker exec 容器ID /etc/init.d/nginx start && sudo docker exec 容器ID /etc/init.d/php-fpm-56 start && sudo docker exec 容器ID /etc/init.d/mysqld start

相关文章

汇成免费订单系统V11.5

汇成免费订单系统V11.5***********************************声明:本系统永久免费!!!***********************************官方下载...

centos7 Firewall防火墙开启80端口[转]

 centos7 默认是FirewallD 提供支持网络/防火墙区域(zone)定义网络链接以及接口安全等级的动态防火墙管理工具,利用FirewallD开启80端口操作如下:开启80端口fi...

win10删除远程桌面记录

HKEY_CURRENT_USER \ Software\Microsoft  \ Terminal ServerClientDefault...

GIt后悔药:还原提交操作(谨慎操作)

GIt后悔药:还原提交操作(谨慎操作)

GIt后悔药:还原提交操作(谨慎操作)一、背景:偶尔会遇到git的版本分支的文件被误改的情况,需要还原,此篇文章可能会帮助到你。PS:来理解下 Git 工作区、暂存区和版本库概念,可以更好的理解以下的...

批量修改文件后缀名

新建***.bat在里面写入ren *.* *.gif运行***.bat...

云图框架

 https://themes.getbootstrap.com/云图框架 ...

发表评论    

◎欢迎参与讨论,请在这里发表您的看法、交流您的观点。