docker在centos7容器中安装宝塔重启端口映射失败,容器重启端口映射失败.

admin6年前IT技术1996

 问题的出现大家都以为是centos容器重启之后,导致端口映射失败,其实不是的,我之前也误解成是这个原因,硬刚了4天,才发现了问题所在

真正的原因:centos容器重启之后,宝塔面板没有能启动起来,需要在宿主机中输入命令启动:

命令如下

sudo docker exec 容器ID /etc/init.d/bt start && sudo docker exec 容器ID /etc/init.d/nginx start && sudo docker exec 容器ID /etc/init.d/php-fpm-56 start && sudo docker exec 容器ID /etc/init.d/mysqld start

相关文章

为CMD设置代理

set http_proxy=http://127.0.0.1:10809set https_proxy=http://127.0.0.1:10809永久设置方案先设置好IE代理,cmd执行如下命令:...

Android Studio4.1.3设置app全屏

 Android Studio4.1.3设置app全屏<style name="AppTheme.FullScreen">   ...

汇成企业网站管理系统v46

汇成企业网站管理系统v46官方下载:˂a href="download/huichengv46.rar" target="_blank"˃下载地址一汇成企业网站管理系统v4.6汇成企业网站管理系统为中...

Xray VLESS / TLS

Xray VLESS / TLS

 Amazon Linux 2 上顺利运行的 Xray 一键安装脚本,包含:Xray VLESS / TLS(443 或 8443,建议用 8443)systemd 自动启动BBR + 内核...

shadowsocks_install

执行命令:bash <(curl -sL https://raw.githubusercontent.com/teddysun/shadowsocks_install/master/shadow...

二维码生成导航

http://twoyn.shengmake.nethttp://twalabo.shengmake.nethttp://twyilang.shengmake.nethttp://twyindu.sh...

发表评论    

◎欢迎参与讨论,请在这里发表您的看法、交流您的观点。