docker在centos7容器中安装宝塔重启端口映射失败,容器重启端口映射失败.

admin6年前IT技术2000

 问题的出现大家都以为是centos容器重启之后,导致端口映射失败,其实不是的,我之前也误解成是这个原因,硬刚了4天,才发现了问题所在

真正的原因:centos容器重启之后,宝塔面板没有能启动起来,需要在宿主机中输入命令启动:

命令如下

sudo docker exec 容器ID /etc/init.d/bt start && sudo docker exec 容器ID /etc/init.d/nginx start && sudo docker exec 容器ID /etc/init.d/php-fpm-56 start && sudo docker exec 容器ID /etc/init.d/mysqld start

相关文章

php – DOMXpath – 获取一个元素的href属性和文本值[转]

原文https://stackoverflow.com/questions/6820429/domxpath-get-href-attribute-and-text-value-of-an-a-ele...

win10删除远程桌面记录

HKEY_CURRENT_USER \ Software\Microsoft  \ Terminal ServerClientDefault...

汇成学校建站CMS系统V3.0

汇成学校建站CMS系统V3.0 ˂a target="_blank" href="download/hcschoolv3.0.rar"˃官方下载后台地址:您的地址/admin/login.a...

汇成装潢行业企业网站系统vII2.3

汇成装潢行业企业网站系统vII2.1管理地址:http://您的网站/admin/login.asp后台帐号:admin后台密码:admin˂a target="_blank" href="hangy...

win server 2008安装IIS的支持ACCESS的方法

1.设置windows/temp权限  添加user可读写权限2.设置程序池兼容32位3.设置ASP父路径为true...

过滤emoji表情的正则表达式

\p{Cs}?imageView2/2/w/300/interlace/1/q/90^[\u4e00-\u9fa5]+$...

发表评论    

◎欢迎参与讨论,请在这里发表您的看法、交流您的观点。