docker在centos7容器中安装宝塔重启端口映射失败,容器重启端口映射失败.

admin6年前IT技术1983

 问题的出现大家都以为是centos容器重启之后,导致端口映射失败,其实不是的,我之前也误解成是这个原因,硬刚了4天,才发现了问题所在

真正的原因:centos容器重启之后,宝塔面板没有能启动起来,需要在宿主机中输入命令启动:

命令如下

sudo docker exec 容器ID /etc/init.d/bt start && sudo docker exec 容器ID /etc/init.d/nginx start && sudo docker exec 容器ID /etc/init.d/php-fpm-56 start && sudo docker exec 容器ID /etc/init.d/mysqld start

相关文章

让MobaXterm能自动显示服务器的cpu与内存使用情况

 Settings→SSH→勾选Remote-monitoring...

Linux报 “permission denied” 异常的原因以及解决办法

Linux报 “permission denied” 异常的原因以及解决办法Linux报 permission denied (权限被拒绝)错误通常是由于当前用户缺少执行该文件或文件夹的权限而导致的。...

excel引用另外一个sheet里的数据

公式如下=Sheet3!H6...

小米手机安装google play store的方法

MIUI的版本必须在>=12.5.9之上没有就必须升级打开账号与同步然后打开谷歌服务就ok了...

Hyper-V虚拟机固定IP地址(手把手教设置)

链接虚拟机修改网络配置文件输入指令sudo vi /etc/sysconfig/network-scripts/ifcfg-eth0然后 输入  按  i  键 再按回车...

发表评论    

◎欢迎参与讨论,请在这里发表您的看法、交流您的观点。