docker在centos7容器中安装宝塔重启端口映射失败,容器重启端口映射失败.

admin6年前IT技术1994

 问题的出现大家都以为是centos容器重启之后,导致端口映射失败,其实不是的,我之前也误解成是这个原因,硬刚了4天,才发现了问题所在

真正的原因:centos容器重启之后,宝塔面板没有能启动起来,需要在宿主机中输入命令启动:

命令如下

sudo docker exec 容器ID /etc/init.d/bt start && sudo docker exec 容器ID /etc/init.d/nginx start && sudo docker exec 容器ID /etc/init.d/php-fpm-56 start && sudo docker exec 容器ID /etc/init.d/mysqld start

相关文章

KindEditor设置网址绝对路径

 KindEditor 4.1.2版本,在上传图片的时候 设置为绝对路径被这个问题困扰了很久,最终搞定,竟然是如此之简单。   方法如下:   1、打...

VB封装ASP 记录集

 定义字符VERSION 1.0 CLASSBEGIN  MultiUse = -1  'True ...

未命名

<?phpnamespace Article;class Comment { }namespace MessageBoard;class Comment { }//调用当前空间(MessageB...

美国年轻人都在玩哪些App[转]

美国年轻人都在玩哪些App[转]

Facebook 它对我们这个年龄的人来说已经死了,Facebook 是我们中学时候玩儿的,但是现在就像尴尬的家庭晚宴一样鸡肋,你会经常遇到这个问题:「别人都用 Facebook,你怎么不用?」(貌似...

Android Studio4.1.3设置app全屏

 Android Studio4.1.3设置app全屏<style name="AppTheme.FullScreen">   ...

vb设置全屏与设置退出--快捷键

退出VB   unload meVB全屏:Form1.Left = 0Form1.Top = 0Form1.Width = Screen.WidthForm1.Height = S...

发表评论    

◎欢迎参与讨论,请在这里发表您的看法、交流您的观点。