docker在centos7容器中安装宝塔重启端口映射失败,容器重启端口映射失败.

admin6年前IT技术1999

 问题的出现大家都以为是centos容器重启之后,导致端口映射失败,其实不是的,我之前也误解成是这个原因,硬刚了4天,才发现了问题所在

真正的原因:centos容器重启之后,宝塔面板没有能启动起来,需要在宿主机中输入命令启动:

命令如下

sudo docker exec 容器ID /etc/init.d/bt start && sudo docker exec 容器ID /etc/init.d/nginx start && sudo docker exec 容器ID /etc/init.d/php-fpm-56 start && sudo docker exec 容器ID /etc/init.d/mysqld start

相关文章

L2TP服务器,同一个局域网只能连接一台客户端的解决方案

 l2tp同一台服务器, 在一个局域网多个账号不能同时登陆的解决方案原因:由于同一个局域网交换机,一般都是一层交换机,承载不了1个以上的IPSEC的加密解决方案:关闭IPSEC加密就可以多账...

php缓存技术

<?php for($i=0;$i<=5;$i++){echo $i."<br/>";ob_flush();//这里是刷新php缓冲区flush();//这...

不同思想管理不同员工

不同思想管理不同员工普通员工最重要的是有较强的责任心,能干好交给他们必须完成的基础工作。这些员工也许只要求企业能给一个较高的收入、工作相对稳定且尽可能少地承担各种风险,不能要求他们对企业绝对的忠诚。这...

php DOMXPath抓取div标签的值的方法

 <?php $url="####";$amz_url=file_get_contents($url);$dom = new DOMDocument();...

google关键词规划师的使用方法

第一步:设置国家第二步:设置语言第三部:设置上一步的同语系的关键词 如果没有第一步与第二步  会导致没有关键词提示!!!!...

VB封装ASP 记录集

 定义字符VERSION 1.0 CLASSBEGIN  MultiUse = -1  'True ...

发表评论    

◎欢迎参与讨论,请在这里发表您的看法、交流您的观点。