docker在centos7容器中安装宝塔重启端口映射失败,容器重启端口映射失败.

admin6年前IT技术1993

 问题的出现大家都以为是centos容器重启之后,导致端口映射失败,其实不是的,我之前也误解成是这个原因,硬刚了4天,才发现了问题所在

真正的原因:centos容器重启之后,宝塔面板没有能启动起来,需要在宿主机中输入命令启动:

命令如下

sudo docker exec 容器ID /etc/init.d/bt start && sudo docker exec 容器ID /etc/init.d/nginx start && sudo docker exec 容器ID /etc/init.d/php-fpm-56 start && sudo docker exec 容器ID /etc/init.d/mysqld start

相关文章

美国年轻人都在玩哪些App[转]

美国年轻人都在玩哪些App[转]

Facebook 它对我们这个年龄的人来说已经死了,Facebook 是我们中学时候玩儿的,但是现在就像尴尬的家庭晚宴一样鸡肋,你会经常遇到这个问题:「别人都用 Facebook,你怎么不用?」(貌似...

magento1.9x在windows10环境下安装遇到的问题及解决方法

win10 wamp环境安装php7126   CURL组件安装之后需要重启电脑,不然不生效apache 开通伪静态功能:需要把#LoadModule access_compat_...

国内较大的游戏平台

37\贪玩\悦玩\4399...

Apache的几种常用配置

Apache是世界使用排名第一的Web服务器软件。它可以运行在几乎所有广泛使用的计算机平台上,由于其跨平台和安全性被广泛使用,是最流行的Web服务器端软件之一。     ...

在hyper-v安装centos7后与windows10共享文件夹

 挂载Windows共享文件夹的方法:1.在windows10宿主机下新建一个共享文件夹,比如叫share_win,并将其设为共享文件夹。2.在CentOS下,执行命令:mount ...

发表评论    

◎欢迎参与讨论,请在这里发表您的看法、交流您的观点。